Skip to main content

j2se is obsolete.. use jdk instead

Posted by alexanderschunk on October 11, 2007 at 1:06 PM PDT

j2se is obsolete: Really?

When reading Kelly Oheirs Glossary for OpenJDK i noticed far below an entry running:

j2se

".....: this is an old word. Use jdk instead. Never let marketing control your products versioning number"

Is SUN really going to change its marketing driven Versioning system of Java SDKs and use a new more reasonably and straightforward system? Will we only have jdk7, jdk8, jdk9 in the future?

That would help many people working with Java releases. For instance if you are applying for a job you just need to write "knows jdk7 and jdk8 with J2EE5.".

What an achievement. Anyone would understand it. Compare this with the following statement no one would understand on first sight:

"Have excellent Java programming skills, know OpenJDK6, OpenJDK7, J2EE 5.5 and J2SE.".

Having a solid and straight forward versioning system will really help people to talk over the same things and technologies rather than trying to explain what they mean.