Skip to main content

WSIT plugin in NetBeans 6

Posted by arungupta on March 5, 2007 at 9:24 AM PST

After being able to deploy and invoke a Web service using NetBeans
6
, I tried
to install the latest
development build of WSIT plug-in
. One big difference (in terms of
ease-of-use) I noticed, from NB 5.5.1 Update Center, is that all the
available modules are now organized in logical categories. And this is nice
because it lets you look for a module in that category. 



NetBeans 5.5.1 Update Center


NetBeans 6 Update Center

Read about cool
modules in NetBeans 6
. But then the number of modules is so many that you
have to scroll through the entire list to find out the availability of your
module from the Update Center. I think a sort feature, as
in the Module Manager
, would be helpful. This will allow a user to find out
if the module is available from Update Center or needs to be downloaded and
installed manually. For example, I had to go through the possible categories to
figure out if WSIT module is available or not. The WSIT plug-in is not available
in Development Update Center, yet. 

So I downloaded the latest
development build of WSIT plug-in
and tried installing it manually following
#ws4.
But then I got the following error.

Martin Grebac, WSIT
plug-in author, told me that all the efforts are currently focused on NetBeans
5.5.1 and there are API changes between the two versions. So it might be
sometime before WSIT plug-in will be supported. In the meanwhile, enjoy WSIT
capabilities in NetBeans IDE 5.5.1. I'll try Enterprise Pack in next few days
and then report back.

Technorati: NetBeans
GlassFish Web
services
WSIT

Related Topics >>