Skip to main content

JAX-WS RI 2.1.4 Released

Posted by jitu on May 13, 2008 at 4:19 PM PDT


JAX-WS RI 2.1.4 Released

JAX-WS RI team is pleased to announce the release of 2.1.4 version. It is also included in Metro 1.2

It has two features:

Lot of bug fixes:

The bits are also pushed to the JAX-WS Maven repository.

Metro 1.2 has woodstox as the default StAX parser. If you are using MTOM, you will run into this bug. The workaround is to put sjsxp.jar first in the classpath or use system properties to enable sjsxp StAX parser.

Continue sending your feedback to the forum and to the mailing list.


Comments

Hello Jitu, A very quick query. Sorry, if you feel that this is a very very basic question. I just now installed Jdk 6 update 6. It comes with JAX-WS RI 2.1.1. Now I would like to use to latest jax-ws 2.1.4. I have downloaded from the location you have specified and unjarred the files in a temporary directory. I consulted the release notes on how to instruct the java run time to use these files. It states, "In order to run JAX-WS RI 2.1.4 you would need to put the jars in the classpath". I am not clear how to do this? Should I put the files in the C:\Program Files\Java\jdk1.6.0_06\jre\lib or C:\Program Files\Java\jdk1.6.0_06\lib Thanks a lot in advance