Skip to main content

Tracking JSR-223 Changes

Posted by robc on July 18, 2006 at 5:33 PM PDT

In Mustang b91, the JSR-223 API was updated to fix some issues around the Invocable interface. Sundar's blog entry has all the details.

We updated the Phobos code in CVS to use the new API, but the latest binary build (dated 2006/7/10) predates this change.

The practical consequences for Phobos users are the following:

  • To run the 7/10 Phobos build on JDK 1.6 you need a Mustang build earlier than b91.
  • If you want to use the latest scripting engines from the scripting project with Phobos, you need to build Phobos from CVS and use Mustang b91 or later.
  • The next binary build of Phobos will require Mustang b91 or later.

Finally, this change won't impact anyone running Phobos on JDK 1.5.

Related Topics >>